Installer LaTeX sous Linux

De Ensiwiki
Aller à : navigation, rechercher

sous Ubuntu

Pour la version 6.10 (Edgy Eft) et les versions ultérieures (Feisty Fawn, Gutsy Gibbon, Hardy Heron, Intrepid Ibex), le paquet de référence à installer pour utiliser LaTeX est le paquet texlive (si vous entendez parler de tetex, celui-ci n'est plus maintenu i.e. il n'y a plus de mise à jour)

Pour l'installation minimale :

sudo apt-get install texlive

Pour ne pas se prendre la tête avec certaines erreurs de compilation et disposer de tous les paquetages nécessaires pour éditer en LaTeX, préférez :

sudo apt-get install texlive-full

Attention, cependant, c'est plus volumineux ;-)

Pour plus de détails, rendez-vous sur la documentation LaTeX du site ubuntu-fr.org.

Pour parfaire votre installation, on peut installer Kile comme éditeur LaTeX. En effet, celui-ci est intuitif (beaucoup d'icônes !) et gère l'auto-complétion des commandes LaTeX.

sudo apt-get install kile

Bien sûr, les éditeurs classiques comme Emacs ou Vim sont également très bons éditeurs pour LaTeX.