Discussion:Installer les outils Xilinx sur sa machine personnelle : Différence entre versions

De Ensiwiki
Aller à : navigation, rechercher
m (libstdc++5)
Ligne 1 : Ligne 1 :
 +
== Bibliothèque libstdc++5 et Ubuntu ==
 +
 +
Il se peut que la commande "sudo aptitude install libstdc++5" ne trouve plus le paquet libstdc++5 sous Ubuntu 9.10. On peut fort heureusement le remplacer par le paquet Debian sans soucis (http://packages.debian.org/stable/base/libstdc++5).
 +
--[[Utilisateur:Roussilp|Roussilp]] 26 février 2010 à 22:07 (UTC)
 +
 
== Problème sous Gentoo ==
 
== Problème sous Gentoo ==
  

Version du 26 février 2010 à 22:07

Bibliothèque libstdc++5 et Ubuntu

Il se peut que la commande "sudo aptitude install libstdc++5" ne trouve plus le paquet libstdc++5 sous Ubuntu 9.10. On peut fort heureusement le remplacer par le paquet Debian sans soucis (http://packages.debian.org/stable/base/libstdc++5). --Roussilp 26 février 2010 à 22:07 (UTC)

Problème sous Gentoo

J'ai eu un problème sous Gentoo : l'installation s'est déroulée sans problème mais après avoir lancé ise, pas moyen de compiler, simuler quoi que ce soit. Dans la console j'obtenais tout un tas d'erreurs concernant tcl. Cela était dû à un conflit avec ma version de la libtcl. Pour résoudre la problème, il suffit de faire:

export LD_PRELOAD=$XILINX/bin/lin/libtcl8.4.so

après avoir sourcé settings.sh --Michell 1 avril 2009 à 19:53 (UTC)

Hum, devrait plutôt être :

LD_LIBRARY_PATH="$XILINX/bin/lin:$LD_LIBRARY_PATH"

À mon avis. Et je pense que c'est dans le script à sourcer avant de lancer Xilinx. Ils disent bien de le sourcer avant d'essayer. --Len 2 avril 2009 à 19:35 (UTC)

Plutôt, oui. LD_LIBRARY_PATH donne la priorité aux bibliothèques fournies avec Xilinx, alors que le LD_PRELOAD va charger cette bibliothèque (et conserver les symboles) avant de lancer Xilinx, qui chargera aussi la bibliothèque du système. Ça doit marcher, mais c'est un peu sale ... --Moy 3 avril 2009 à 09:59 (UTC)

Hum désolé d'insister, mais j'ai réessayé, et si je ne set pas la variable $LD_PRELOAD après avoir sourcer settings.sh, et avant de lancer ise, rien ne fonctionne...--Michell 6 avril 2009 à 21:22 (UTC)